User Guide for Single Depth Sensor Configuration

From iPi Docs
Jump to: navigation, search

Contents

System Requirements

iPi Recorder

  • Computer (desktop or laptop):
    • CPU: x86 compatible (Intel Pentium 4 or higher, AMD Athlon or higher, 2GHz), dual- or quad- core is preferable
    • Operating system: Windows 10 / 8.1 / 8 / 7 (32-bit or 64-bit)
    Important.png
    Important! Kinect 2 for Windows, Kinect for Xbox One requires USB 3.0 controller. Kinect SDK 2.0 currently supports only single sensor on one PC.
  • Microsoft Kinect 2 for Windows / for Xbox One, or Microsoft Kinect
Note.png
Note: For Microsoft Kinect for Xbox One you will need Microsoft Kinect Adapter cable

iPi Mocap Studio

  • Computer (desktop or laptop):
    • CPU: x86 compatible (Intel Pentium 4 or higher, AMD Athlon or higher), dual- or quad- core is preferable.
    • Operating system: Windows 10 / 8.1 / 8 / 7 (32-bit or 64-bit).
    • Video card: DirectX 11 capable gaming-class graphics card.
GPUz example.gif

Software Installation

iPi Recorder

Important.png
Important! Please unplug all cameras from computer before installation.

Download and run the setup package of the latest version of iPi Recorder. You will be presented with the following dialog.

iPi Recorder 3 Setup.png
  1. Select needed components
  2. Read and accept the license agreement by checking appropriate checkbox
  3. Press the Install button to begin installation
Note.png
Note: Most of the components require administrative privileges because they install device drivers or write to Program Files and other system folders. You will be presented with UAC prompts when appropriate during installation. If you plan to use iPi Recorder under user which has no administrative rights, you can pre-install other components separately using administrator's account.
Important.png
Important!
  1. You can plug only one depth sensor to one USB controller. Single USB controller bandwidth is not enough to record from 2 sensors.
  2. You can plug not more than 2 Sony PS Eye cameras to one USB controller, otherwise you will not be able to capture at 60 fps with 640 x 480 resolution.
For more info see USB controllers.

Upon installation is complete, iPi Recorder will launch automatically. Continue with user's guide to get a knowledge of using the software.

Components

If some of the components is already installed, it has no checkbox and is marked with ALREADY INSTALLED label. You should not install all optional components in advance, without necessity. All of them can be installed separately at later time. Components descriptions below contain corresponding download links.

  • (Windows 8, 8.1, 10) Microsoft Kinect 2:: MS Kinect SDK 2.0. Check if you plan to work with Kinect 2 for Windows or Kinect for Xbox One depth sensors.
    Device drivers and software libraries for Microsoft Kinect 2. Requires Windows 8 and USB 3.0.
  • iPi Recorder 3.x.x.x. This is required component and cannot be unchecked.
    iPi Recorder itself.

iPi Mocap Studio

Download and run the latest setup package of iPi Mocap Studio. You will be presented with the following dialog:

iPi Mocap Studio 3 Setup.png

All components are required for installation.

Note.png
Note: The installation of Microsoft .NET Framework 4.5.1 requires an Internet connection. If needed, you can download offline installer for Microsoft .NET separately, and run it before iPi Mocap Studio setup.

Other components are included with iPi Mocap Studio setup.

Note.png
Note: Shell Extensions for Video and Project files are needed to show thumbnails and preview for iPi video and project files in Windows Explorer
  1. Press the Install button to begin installation.
  2. You will be prompted to read and accept the license agreement(s) by checking corresponding checkbox.
    iPi Mocap Studio 3 Setup Accept License.png
    Click to enlarge
    Click to enlarge
  3. Press the Install button to begin installation.
  4. Upon installation is complete, you will be prompted to launch iPi Mocap Studio.
    iPi Mocap Studio 3 Setup Launch.png
  5. As soon as iPi Mocap Studio launches, you will be prompted to enter your license key or start 30-days free trial period.
    For more info about license protection see Licensing Policy.
    Welcome to ipistudio dlg.png
  6. Ensure that your graphics hardware is set to maximum performance with iPi Mocap Studio.

Recording Video from Depth Sensor

Finally, after all these preparations completed, you are ready for performance.

Environment

Minimum space requirements for depth sensor configurations depend on sensor model and number of sensors:

Configuration Kinect 2 (Kinect for Xbox One) Kinect
Single Depth Sensor

8 by 5 feet = 2.5 by 1.5 meters

10 by 10 feet = 3.0 by 3.0 meters

2 Depth Sensors

8 by 8 feet = 2.5 by 2.5 meters

10 by 10 feet = 3.0 by 3.0 meters

3+ Depth Sensors

16 by 16 feet = 5 by 5 meters

20 by 20 feet = 6 by 6 meters

Maximum capture area is about 7 by 7 feet ( = 2 by 2 meters), for all sensor models and configurations.

It is convenient to put MS Kinect Sensor on a chair or a table. The picture below will help you to understand possible capture area and required space. Dimensions are different for Kinect and Kinect 2 (Kinect for Xbox One) sensors due to different field of view.

Kinect 2 for Windows and Kinect for Xbox One

Kinect 2 (Kinect for Xbox One) sensors have wider angle of view compared to first generation Kinect. This makes possible to come closer to sensor thus decreasing overall space requirements.

Click to enlarge
Click to enlarge
Side view
Top view

First Generation Kinect

Click to enlarge
Click to enlarge
Side view
Top view

Actor Clothing

Current version uses only depth information to track motions. So clothes requirements are:

  • no restrictions on clothes colors (just avoid shiny fabrics)
  • please use slim clothes to reduce noise in resulted animation

Recording Process

Please record a video using iPi Recorder application. It supports recording with Sony PS Eye cameras, depth sensors (Kinect) and DirectShow-compatible webcams (USB and FireWire).

iPi Recorder is a stand-alone application and does not require a powerful video card. You may choose to install it on a notebook PC for portability. Since it is free, you can install it on as many computers as you need.

Please run iPi Recorder and follow recording workflow as described in user's guide for the program.

Tip.png
Tip: Have a look at a list of recommendations to avoid hardware performance problems during recording.

Recording Actor's Performance

After completing Setup and Background recording steps, press Record button to begin video recording. To stop recording, press Stop button.

Recommended Layout of an Action Video

  • Enter the actor.
  • Strike a T-pose.
  • Action
Click to enlarge

T-Pose

As soon as recorder starts, go to the capture area and stand in a T-pose. After that you can act desired motions.

Tip.png
Tip: Sometimes it is inconvenient or not possible to stand in T-Pose. You can do without it, but in this case initial alignment of actor model in iPi Mocap Studio will require more manual actions.

If you make several takes of one actor, we recommend to strike a T-pose in the beginning of each take.

Tip.png
Tip: We use tracking data from modern depth sensors for workflow improvements. You can get most of it if you follow recommendations described here.

Takes

Take is a concept originating from cinematography. In a nutshell, take is a single continuous recorded performance.

Usually it is a good idea to record multiple takes of the same motion, because a lot of things can go wrong for purely artistic reasons.

Iterations

A common problem with motion capture is “clipping” in resulting 3D character animation. For example, arms entering the body of animated computer-generated character. Many CG characters have various items and attachments like a bullet-proof vest, a fantasy armor or a helmet. It can be easy for an actor to forget about the shape of the CG model.

For this reason, you may need to schedule more than one motion capture session for the same motions. Recommended approach is:

  • Record the videos
  • Process the videos in iPi Mocap Studio
  • Import your target character into iPi Mocap Studio and review the resulting animation
  • Give feedback to the actor
  • Schedule another motion capture session if needed

Ian Chisholm's hints on motion capture

Ian Chisholm is a machinima director and actor and the creator of critically acclaimed Clear Skies machinima series. Below are some hints from his motion capture guide based on his experience with motion capture for Clear Skies III.

Three handy hints for acting out mocap:

  1. Don’t weave and bob around like you’re in a normal conversation – it looks terrible when finally onscreen. You need to be fairly (but not completely) static when acting.
  2. If you are recording several lines in one go, make sure you have lead in and lead out between each one, i.e. stand still! Otherwise, the motions blend into each other and it’s hard to pick a start and end point for each take.
  3. Stand a bit like a gorilla – have your arms out from your sides:
    Gorilla.jpg

    Well, obviously not quite that much. But anyway, if you don’t, you’ll find the arms clip slightly into the models and they look daft.

If you have a lot of capture to do, you need to strike a balance between short and long recordings. Aim for 30 seconds to 2 minutes. Too long is a pain to work on later due to the fiddlyness of setting up takes, and too short means you are forever setting up T-poses.

Takes

Because motion capture is not a perfect art, and neither is acting, it’s best to perform multiple takes. I found that three was the best amount for most motion capture. Take less if it’s a basic move, take more if it’s complex and needs to be more accurate. It will make life easier for you in the processing stage if you signal the break between takes – I did this by reaching out one arm and holding up fingers to show which take it was.

Naming conventions

As it’s the same actor looking exactly the same each and every time, and there is no sound, and the capture is in lowres 320*200, you really need to name the files very clearly so that you later know which act, scene, character, and line(s) the capture is for.

My naming convention was based on act, scene, character, page number of the scene, line number, and take number. You end up with something unpleasant to read like A3S1_JR_P2_L41_t3 but it’s essential when you’ve got 1500 actions to record.

Processing Video from Depth Sensor

  • Run iPi Mocap Studio
  • Press Ctrl+N or push New button on toolbar to create new project (1)
  • Choose recorded *.iPiVideo file
  • After video opened, the floor will be calculated automatically and position of camera will be detected based on floor plane.
  • Make sure, that floor is detected correctly:
    1. Right mouse button down on 3d view port area
    2. Move mouse, as a result 3d scene will be rotated
    3. Right mouse button up
    4. Visually control that 3d points from floor are located on ground plane which is marked by squared grid
KSensor-process-step2.png
Note.png
Note: You always can get back to the camera point of view by pressing 1 key on keyboard or pushing “Camera 1” button on toolbar
  • Save created project by pressing Ctrl+S or pushing button Save on toolbar (2)
  • Position timeline slider to the frame where actor is in T-pose (3)
  • Adjust actor height using appropriate slider on tab Actor (4)
  • Select Move tool on toolbar. (5)
  • Move actor model to left or right to match roughly actor silhouette on video.
Note.png
Note: Actor model can look smaller due to its position along axis of view. Don’t pay attention to it on this step.
KSensor-process-step3.png
KSensor-process-step4-1.png
  • Switch to Tracking tab and push Refit pose button. (6)
  • As a result model should be matched with actor image from video. If it does not happen then delete result using item Edit > Delete pose from main menu and repeat above actions.
  • Using the slider right to the button Show Skin in toolbar, make sure that morph of model corresponds to the actor image (7).
    • If no, than adjust chest/bust/waist/hips/belly morph using appropriate sliders from Actor tab (8).
  • Set the beginning of Region-of-Interest (ROI) to the current frame with T-pose by pressing I key on keyboard or by double-clicking on the left edge of ROI bar under timeline (7).
  • Switch to Tracking tab, change tracking options (Head tracking, Shoulders and Spine) if required (9).
Tip.png
Tip: Check Use fast tracking algorithm (BETA) option to use fast algorithm. This option only affects Track Forward / Track Backward. This algorithm may be less accurate in some cases, but its tracking speed is up to 2.5 times higher, depending on particular hardware and tracking options.
  • To start tracking just push Track Forward button (10).
  • Wait and watch...
Note.png
Note: Use old tracking algorithm option (11) allows to switch to old algorithm. You can use this in case default tracking crashes (rare case).

Tracking Tips and Tricks

Using Pose Mismatch View

Pose Mismatch window is a very useful tool which allows you to understand how actor settings affect tracking.

  • Pose Mismatch window is shown using View > Pose Mismatch menu item
  • Mismatch number at the top evaluates how actor model matches to video in the current frame
  • You need to run Refit Pose to match actor model to video before comparing Mismatch numbers
  • Lower value of Mismatch number means better match. So your need to minimize Mismatch number while choosing settings
Note.png
Note: When Mismatch number is negative, then greater absolute value means better match.
Pose Mimatch View

Manual Clean-up

Once initial tracking is performed on all (or part) of your video, you can begin cleaning out tracking errors (if any). Automatic Refinement and Filtering should be applied after clean-up.

Cleaning up tracking gaps

Tracking errors usually happen in a few specific video frames and propagate to multiple subsequent frames, resulting in tracking gaps. Examples of problematic frames:

  • Occlusion (like one hand not visible in any of the cameras)
  • Indistinctive pose (like hands folded on chest).
  • Very fast motion with motion blur.

To clean up a sequence of incorrect frames (a tracking gap), you should use backward tracking:

Clean-up Steps
  1. Go toward the last frame of tracking gap, to a frame where actor pose is distinctive (no occlusion, no motion blur etc.).
  2. If necessary, use Rotate, Move and IK (Inverse Kinematics) tools to edit character pose to match actor pose on video.
  3. Turn off Trajectory Filtering (set it to zero) so that it does not interfere with your editing.
  4. Click Refit Pose button to get a better fit of character pose.
  5. Click Track Backward button.
  6. Stop backward tracking as soon as it comes close to the nearest good frame.
  7. If necessary, go back to remaining parts of tracking gap and use forward and backward tracking to clean them up.

Cleaning up individual frames

To clean up individual frames you should use a combination of editing tools (Rotate, Move and Inverse Kinematics) and Refit Pose button.

Note.png
Note: after Refit Pose operation iPi Mocap Studio automatically applies Trajectory Filtering to produce a smooth transition between frames. As the result, pose in current frame is affected by nearby frames. This may look confusing. If you want to see exact result of Refit Pose operation in current frame you should turn off Trajectory Filtering (set it to zero), but do not forget to change it back to suitable value later.

Tracking errors that cannot be cleaned up using iPi Studio

Not all tracking errors can be cleaned up in iPi Mocap Studio using automatic tracking and Refit Pose button.

  • Frames immediately affected by occlusion sometimes cannot be corrected. Recommended workarounds:
    • Manually edit problematic poses (not using Refit Pose button).
    • Record a new video of the motion and try to minimize occlusion.
    • Record a new video of the motion using more cameras.
  • Frames immediately affected by motion blur sometimes cannot be corrected. Recommended workarounds:
    • Manually edit problematic poses (not using Refit Pose button).
    • Edit problematic poses in some external animation editor.
    • Record a new video of the motion using higher framerate.
  • Frames affected by strong shadows on the floor sometimes cannot be corrected. Typical example is push-ups. This is a limitation of current version of markerless mocap technology. iPi Soft is working to improve tracking in future versions of iPi Mocap Studio.

Automatic Refinement and Filtering

Automatic Refinement and Filtering should be applied after Manual Clean-up, if there were tracking errors.

Also, this final step is called Post-Processing and includes:

Clean-up Steps
  1. Tracking Refinement
  2. Jitter Removal
  3. Trajectory Filtering

Tracking refinement

After the primary tracking and cleanup are complete, you can optionally run the Refine pass (see Refine Forward and Refine Backward buttons). It slightly improves accuracy of pose matching, and can automatically correct minor tracking errors. However, it takes a bit more time than the primary tracking, so it is not recommended for quick-and-dirty tests.

Important.png
Important! Refine should be applied:
  • Using the same tracking parameters as the primary tracking (e.g. feet tracking, head tracking) in order not to lose previously tracked data.
  • Before motion controller data.
  • If you plan to manually edit the animation (not related to automatic cleanup with Refit Pose).

In contrast to the primary tracking, Refine does no pose prediction. It is based on the current pose in a frame only. Essentially, running Refine is equal to automatically applying Refit Pose to a range of frames which were previously tracked.

Post-processing: Jitter Removal

  • Jitter Removal filter is a powerful post-processing filter. It should be applied after cleaning up tracking gaps and errors.
  • It is recommended that you always apply Jitter Removal filter before exporting animation.
  • Jitter Removal filter suppresses unwanted noise and at the same time preserves sharp, dynamic motions. By design, this filter should be applied to relatively large segments of animation (no less than 50 frames).
  • Range of frames affected by Jitter Removal is controlled by current Region of Interest (ROI).
  • You can configure Jitter Removal options for specific body parts. Default setting for Jitter Removal “aggressiveness” is 1 (one tick of corresponding slider). Oftentimes, you can get better results by applying a slightly more aggressive Jitter Removal for torso and legs. Alternatively, you may want to use less aggressive Jitter Removal settings for sharp motions like martial arts moves.
  • Jitter Removal filter makes an internal backup of all data produced by tracking and clean up stages. Therefore, you can re-apply Jitter Removal multiple times. Each subsequent run works off original tracking/clean-up results and overrides previous runs.

Post-processing: Trajectory Filtering

  • Trajectory Filter is a traditional digital signal filter. Its purpose is to filter out minor noise that remains after Jitter Removal filter.
  • Trajectory Filter is very fast. It is applied on-the-fly to current Region of Interest (ROI).
  • Default setting for Trajectory Filter is 1. Higher settings result in multiple passes of Trajectory Filter. It is recommended that you leave it at the default setting.
  • Trajectory Filter can be useful for “gluing” together multiple segments of animation processed with different Jitter Removal options: change the Region of Interest (ROI) to cover all of your motion (e.g. multiple segments processed with different jitter removal setting); change Trajectory Filtering setting to 0 (zero); then change it back to 1 (or other suitable value).

Export and Motion Transfer

Animation Export

To export tracked motion, follow simple steps below.

  1. Select Export tab
  2. Select rig from the list of available rigs or import your custom model
    Note.png
    Note: The motions will be automatically transferred to selected rig (except Default iPi Rig, that does not require motion transfer). See details on motion transfer below)
  3. Press Export button or use File > Export Animation menu item to export all animation frames from within Region of Interest (ROI).
    Note.png
    Note: To export animation for specific take, right-click on take and select Export Animation item from pop-up menu.
  4. Select output file format
ExportTab-1.png

Motion Transfer

Default iPi Character Rig

The default skeleton in iPi Mocap Studio is optimized for markerless motion capture. It may or may not be suitable as a skeleton for your character. Default iPi skeleton in T-pose has non-zero rotations for all joints. Please note that default iPi skeleton with zero rotations does not represent a meaningful pose and looks like a random pile of bones.

Default rig
Bone names

By default iPi Mocap Studio exports a T-pose (or a reasonable default pose for custom rig after motion transfer) in the first frame of animation. In case when it is not desired switch off Export T-pose in first frame checkbox.

Other rigs

iPi Mocap Studio has integrated motion transfer technology that allows to automatically transfer motion to a custom rig.

  1. Select Export tab
  2. Select rig from the list of available rigs or import your custom model
    Note.png
    Note: The motions will be automatically transferred to selected rig (except Default iPi Rig, that does not require motion transfer). You will be able to see the transferred motion in the viewport
  3. You may need to assign bone mappings on the Export tab for motion transfer to work correctly.
  4. You can save your motion transfer profile to XML file for future use.
Tip.png
Tip: iPi Mocap Studio has pre-configured motion transfer profiles for many popular rigs (see below).
Note.png
Note: If you export animation to format different from format your target character was imported in, only rig will be exported. If you use the same format for export, skin will be exported as well.
ExportTab-2.png

Starting with version 3.5, iPi Mocap Studio supports rotation of imported character into proper orientation. This is useful for many popular characters, including Unreal Engine standard character.

Animation-Export-Orientation-1.png

Starting with version 3.5, iPi Mocap Studio can map hips motion either to Root/Ground or to Hips/Pelvis. This is useful for game engine characters, including standard Unity 3D Engine and Unreal Engine characters.

Export-Root-1.png

Export Pipelines for Popular 3D Packages

MotionBuilder

Select Motion Builder target character on Export tab and export animation to BVH or FBX.

export mb.png

3D MAX Biped

  1. Select 3ds Max Biped target character on Export tab and export animation to BVH or FBX.
  2. Create a Biped character in 3D MAX (Create > Systems > Biped).
  3. Put your Biped character to your 3d scene.
  4. Go to Motion tab. Click Motion Capture button and import your BVH or FBX file.
Step 1
Step 2
Step 3
Step 4

Our user Cra0kalo created an example Valve Biped rig for use with 3D MAX. It may be useful if you work with Valve Source Engine characters.

Maya

Latest versions of Maya (starting with Maya 2011) have a powerful biped animation subsystem called "HumanIK". Animations exported from iPi Mocap Studio in MotionBuilder-friendly format should work fine with Maya 2011 and HumanIK. The following video tutorials can be helpful:

For older versions of Maya please see the #Motion Transfer and Custom Rigs section. Recommended format for import/export with older versions of Maya is FBX.

FBX

iPi Mocap Studio supports FBX format for import/export of animations and characters. When exporting animation, you are presented with several options:

  • Which version of FBX format to use, ranging from 6.1 (2010 product line) to 7.4 (2015 product line)
  • Produce text or binary file

The default values are defined by an imported character (if any), otherwise set to recently used values.

Some applications do not use the latest FBX SDK and may have problems importing FBX files of newer versions. In case of such problems, your can use Autodesk's free FBX Converter to convert your animation file to an appropriate FBX version.

COLLADA

iPi Mocap Studio supports COLLADA format for import/export of animations and characters. Current version of iPi Mocap Studio exports COLLADA animations as matrices. In case if you encounter incompatibilities with other applications' implementation of COLLADA format, we recommend using Autodesk's free FBX Converter to convert your data between FBX and COLLADA formats. FBX is known to be more universally supported in many 3D graphics packages.

LightWave

Recommended format for importing target characters from LightWave to iPi Studio is FBX. Recommended format for bringing animations from iPi Mocap Studio to LightWave is BVH or FBX.

SoftImage|XSI

Our user Eric Cosky published a tutorial on using iPi Mocap Studio with SoftImage|XSI:

http://www.ipisoft.com/forum/viewtopic.php?f=13&p=9660#p9660

Poser

  1. Export your poser character in T-pose in BVH format (File > Export).
  2. Import your Poser character skeleton into iPi Mocap Studio. Your animation will be transferred to your Poser character.
  3. Export your animation to BVH format.
  4. Import exported BVH to Poser
Tip.png
Tip: Poser 8 has a bug with incorrect wrists animation import. The bug can be reproduced as follows: export Poser 8 character in T-pose in BVH format; import your character back into Poser 8; note how wrists are twisted unnaturally as the result.
A workaround for wrists bug is to chop off wrists from your Poser 8 skeleton (for instance using BVHacker) before importing Poser 8 target character into iPi Mocap Studio. Missing wrists should not cause any problems during motion transfer in iPi Mocap Studio if your BVH file is edited correctly. Poser will ignore missing wrists when importing resulting motion so the resulting motion will look right in Poser (wrists in default pose as expected).
Step 1
Step 2
Step 3
Step 4

DAZ 3D

  1. In DAZ Studio reset your character to T-pose and correct feet positions as shown on picture below.
  2. Export you DAZ character to BVH with default options.
  3. Import your DAZ character skeleton into iPi Mocap Studio. Your animation will be transferred to your DAZ character.
  4. Export your animation to BVH format.
  5. Import exported BVH to DAZ Studio.
Note.png
Note: You can use DAZ character in COLLADA (.dae) format for preview, but it is strongly recommended that you use DAZ character in BVH format for motion transfer. DAZ3D has a problem with COLLADA (.dae) format: DAZ3D Studio does not export all bones into COLLADA (.dae). In particular, the following bones are not exported: eyeBrow, bodyMorphs. DAZ3D Studio does not use bone names when importing motions; instead, DAZ3D Studio just takes rotations from the list of angles as though it was a flat list with exactly the same positions as in DAZ3D internal skeleton. As the result, when you transfer the motion to a COLLADA character and import it back into DAZ3D, the motion will look wrong. iPi Mocap Studio displays a warning about this. To avoid this problem, import your DAZ target character in BVH format - DAZ3D Studio is known to export characters in BVH format correctly (with all bones).
Tip.png
Tip: You can improve accuracy of motion transfer by doing some additional preparation of your DAZ 3D skeleton in BVH format. For DAZ 3D Michael 4.0 and similar characters, you may need to clamp thigh joint rotation to zero to avoid unnatural leg bending. For DAZ 3D Victoria 4.0, you may need to adjust foot joint rotation to change the default “high heels“ foot pose to a more natural foot pose.
Step 1
Step 2
Step 3
Step 4
Step 5

iClone 3

Note.png
Note: Modern versions of iClone work smoothly with iPi Soft. Instructions below are only for iClone 3
Note.png
Note: Current version of iPi Studio can only export animation in iClone-compatible BVH format. The iMotion format is not supported. That means you will need iClone PRO to be able to import the motion into iClone. Standard and EX versions of iClone do not have BVH Converter and therefore cannot import BVH files.

Workflow for iClone is straightforward.

  1. Select iClone target character on Export tab and export animation to BVH.
  2. Go to Animation tab in iClone and launch BVH Converter.
  3. Import your BVH file with Default profile, click Convert
  4. Save the resulting animation in iMotion format. Now your animation can be applied to iClone characters.
Tip.png
Tip: iClone expects an animation sampled at 15 frames per seconds. For other frame rates, you may need to create a custom BVH Converter profile by copying Default profile and editing Frame Rate setting.
Note.png
Note: BVH Converted in iClone 4 has a bug that causes distortion of legs animation. iPi Mocap Studio exports an iClone-optimized BVH correctly as can be verified by reviewing exported BVH motion in BVHacker or MotionBuilder or other third-party application. No workaround is known. We recommend that you contact iClone developers about this bug as it is out of control of iPi Soft.
Step 1
Step 2
Step 3
Step 4
Step 5

Valve Source Engine SMD

Transfer motions to your Valve Source Engine character (stored in .smd file) and export your animation in Valve Source Engine SMD format.

Our user Cra0kalo created an example Valve Biped rig for use with 3D MAX. It may be useful if you wish to apply more then one capture through MotionBuilder or edit the custom keyframes in MAX.

Valve Source Filmmaker

DMX

First, you need to import your character (or its skeleton) into iPi Mocap Studio, for motion transfer.

There are currently 3 ways of doing this:

  1. You can import an animation DMX (in default pose) into iPi Mocap Studio. Since it has a skeleton, it should be enough for motion transfer. To create an animation DMX with default pose, you can add your character to your scene in Source Filmmaker and export DMX for corresponding animation node:
    • open Animation Set Editor Tab;
    • click + > Create Animation Set for New Model;
    • choose a model and click Open;
    • export animation for your model, in ASCII DMX format;
      There is a checkbox named Ascii in the top area of the export dialog.
  2. Alternatively, you can just import an SMD file with your character into iPi Mocap Studio. For example, SMD files for all Team Fortress 2 characters can be found in your SDK in a location similar to the following (you need to have Source SDK installed): C:\Program Files (x86)\Steam\steamapps\<your steam name>\sourcesdk_content\tf\modelsrc\player\pyro\parts\smd\pyro_model.smd).
  3. If you created a custom character in Maya, you should be able to export it in DMX model fromat. (Please see Valve documentation on how to do this).

Then you can import your model DMX into iPi Mocap Studio. Current version of iPi Mocap Studio cannot display character skin, but it should display the skeleton. Skeleton should be enough for motion transfer.

To export animation in DMX, press Export Animation button on the Export tab in iPi Mocap Studio and choose DMX from the list of supported formats. You may also want to uncheck Export T-pose in first frame option on the Export tab in iPi Mocap Studio.

Now you can import your animation into Source Filmmaker. There will be some warnings about missing channels for face bones but you can safely ignore them.

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Old way involving Maya

This was used until iPi Mocap Studio got DMX support. And still may be useful in case of any troubles with DMX. Please see the following video tutorial series:

http://www.youtube.com/playlist?list=PLD4409518E1F04270

Blender

Select Blender target character on Export tab and export animation to BVH format.

export blender.png

Cinema4D

If you have experience with Cinema4D please help to expand this Wiki by posting Cinema4D import/export tips to Community Tutorials section of our user forum.

Evolver

Transfer motions to your Evolver character (stored in COLLADA or FBX file) and export your animation.

Evolver offers several different skeletons for Evolver characters. Here is an example motion transfer profile for Evolver "Gaming" skeleton: evolver_game.profile.xml

Second Life

Transfer motions to your Second Life character (stored in BVH file) and export your animation in BVH format.

SecondLife documentation contains a link to useful SL avatar files. The ZIP file includes a BVH of the "default pose". Be sure to have that.

See the discussion on our Forum for additional details: http://www.ipisoft.com/forum/viewtopic.php?f=2&p=7845

Massive

Please see our user forum for a discussion of animation import/export for Massive:

http://ipisoft.com/forum/viewtopic.php?f=12&t=3233

IKinema WebAnimate

Please see the following video tutorial on how to use iPi Mocap Studio with IKinema WebAnimate:

http://www.youtube.com/watch?v=a-yJ-O02SLU

Jimmy|Rig Pro

Please see the following video tutorial on how to use iPi Mocap Studio with Jimmy|Rig Pro:

http://www.youtube.com/watch?v=wD1keDh3fCk

Video Materials

Demo video

iPi Mocap Beginners Tutorial from Indecision Studios

"Car scene" by JeanDellac

Animation by NextGenReport