iPi Mocap Studio Release Notes

From iPi Docs
Revision as of 13:30, 17 June 2017 by Vmaslov (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Here you can find history of recent versions of iPi Mocap Studio.

iPi Mocap Studio has built-in auto update functionality. Auto update feature is configured so that checks for update are made once per day. It helps to reduce the start time of the application. If you want to update ASAP — you can use the Help > Check for Update menu item.

Note that both of these features require Internet connection. Alternatively (in case of troubles with auto update), you can download and run the updated installation program from direct link.


ver. 3.6.4.220

Version 3.6.4.220
Jun 17, 2017
Download-24.png  Download

 N E W    F E A T U R E S:

  • Export Options dialog is now shown for any file format after a destination file is selected. Recenter coordinates on character and Export T-pose in the first frame options moved to this dialog (they affect exported animation only). Advanced motion transfer option is left on the Export tab (it affects both preview in program and exported animation), but moved up, just below Show target character option.
  • Option for setting the frame rate of an exported animation is added to the Export Options dialog.
  • Export of cameras is available for COLLADA format.

 B U G    F I X E S:

  • Incorrect vertical positioning of built-in rigs for Motion Builder and 3ds Max.
  • Incorrect positioning of skeleton when exporting with default rig in some situations.
  • Values for selected bone were not displayed on the Pose tab (introduced in 3.6.0).
  • App crash on project opening under certain circumstances.
  • Motion transfer profile was not saved automatically after changing target character’s orientation.


ver. 3.6.3.219

Version 3.6.3.219
May 29, 2017
Download-24.png  Download

 B U G    F I X E S:

  • Applying data from motion controllers fails after saving a project.
  • A number of bugs with Move Coordinate System tool:
    • App crash
    • Frames with default pose were transformed
    • Visual glitches


ver. 3.6.2.218

Version 3.6.2.218
May 26, 2017
Download-24.png  Download

 B U G    F I X E S:

  • Exported animation always has default 30 FPS (introduced in v3.6.0.216).
  • Changes in actor appearance are not applied to the target character.


ver. 3.6.1.217

Version 3.6.1.217
May 25, 2017
Download-24.png  Download

 B U G    F I X E S:

  • Crash of license activation during application start


ver. 3.6.0.216

Version 3.6.0.216
May 25, 2017
Download-24.png  Download

 N E W    F E A T U R E S:

  • New calibration algorithm for the light marker method.
    • Vastly greater speed
    • Slightly better accuracy
Tip.png
Tip: In case of problems with the new algorithm, you can revert to using the old algorithm. Check Use old calibration algorithm in Manual Calibration Adjustments > Advanced Calibration Settings section on the Calibration tab.
  • Including cameras into exported animations in FBX format (optional).
  • Vastly increased the speed of applying data from motion controllers.
  • Automation add-on:
    • Added useFastTrackingAlgorithm field to the arguments of set-tracking-props command and to the result of get-tracking-props command.
    • Added markerColor field to the arguments of run-calibration command.
    • Changed default value of autoDetectInitialCameraPositions field in create-project command to true.

 B U G    F I X E S:

  • Biomech add-on: Unchecking Export RGB checkbox when there is no color data.
  • Fixed app crash after opening project under certain conditions.
  • Fixed displaying of warnings on the Calibration tab at improper moments.
  • Task dialogs after animation/video export were modeless.


ver. 3.5.1.215

Version 3.5.1.215
Apr 23, 2017
Download-24.png  Download

 B U G    F I X E S:

  • Wrong scale in exported DMX animation (see forum message).
  • Program crashed on importing character having same-named bones.

ver. 3.5.0.214

Version 3.5.0.214
Apr 19, 2017
Download-24.png  Download

 N E W    F E A T U R E S:

  • New fast tracking algorithm for depth sensors (BETA version). To use it, turn on Use fast tracking algorithm (BETA) checkbox on Tracking tab.
    • Tracking speed increase is up to 2.5 times depending on particular hardware and tracking options.
    • Available for single-actor projects, and single-GPU configurations.
Tip.png
Tip: If you use 2 GPUs for tracking, you need to turn it off by unchecking second GPU via Help > Manage GPU Usage menu.
  • Improvements in animation export.
    • New control on Export tab to rotate imported characters into proper orientation. This is useful for many popular characters, including standard Unreal Engine character.
    • The motion is now correctly transferred to imported characters with separate Root bone and Hips/Pelvis bone. You can map hips motion either to Root or to Hips/Pelvis. This is useful for game engine characters, including standard Unity 3D Engine and Unreal Engine characters.
    • Support for FBX format 7.5 (2016)
Note.png
Note: Built-in rig for Blender has been removed, because there is no need in change of axes orientation for modern versions of Blender.
  • Allow to select flashlight color for marker detection during calibration (useful in case of light background).
  • Added finger bones to motion transfer profile for Valve characters in SMD and DMX formats.
  • Added hints about GPUs to progress bar area during tracking.
  • Showing dialog with common actions available for the exported file after animation export and video export operations.

 B U G    F I X E S:

  • Program crashed in case of window resizing during video export.
  • Program crashed on certain errors when opening target character and animations. Now errors are reported.
  • Automation Add-on could hang in rare cases during events sending.
  • Fixed GPU memory leaks on project open / close operations and during calibration.

 U N D E R    T H E    H O O D:

  • Improved automatic floor detection both for RGB cameras and depth sensors
  • Replaced viewport repaint on every frame during tracking / refine / jitter removal to repaint by timer. May lead to slight speed increase on powerful GPUs.
  • Improved tracking / refine / jitter removal speed calcualtion and changed formatting for speed values.
  • Using FBX SDK 2017.1 for handling FBX files.
  • Fixed speed degradation issue during calibration using board for depth projects.
  • For multiple GPU configuration the old tracking algorithm is set to be used in case number of cameras is over 6. In most cases this is faster than using default tracking on single GPU.

ver. 3.4.16.212

Version 3.4.16.212
Nov 29, 2016
Download-24.png  Download

 B U G    F I X E S:

  • Import of target character crashed.

ver. 3.4.15.211

Version 3.4.15.211
Nov 29, 2016
Download-24.png  Download

 B U G    F I X E S:

  • Tracking worked incorrectly on Intel integrated graphics and some other weak video cards.
  • Jitter removal / tracking hanged in rare cases.
  • Incorrect pose visualized during tracking in the first frame of Region-of-Interest.
  • Tracking crashed with exception Wait for frame ... failed in rare cases.

 U N D E R    T H E    H O O D:

  • Fixed GPU memory leaks.

ver. 3.4.12.208

Version 3.4.12.208
Oct 13, 2016
Download-24.png  Download

 N E W    F E A T U R E S:

  • Increased speed of tracking operations.
    • Maximum speed increase (up to 3-4 times) is achieved at high-performance video cards for projects recorded with 1 or 2 Kinect sensors.
    • For 4 or more Sony PS3 Eye cameras speed gain is lower and can reach 10 – 50% depending on particular tracking options and hardware configuration.
    • For slow video cards speed increase is substantially lower.
    • For projects recorded with many cameras tracking speed can even be lower compared to previous version on particular hardware configurations. You have the option to use the old tracking algorithm then (you can select this option in Advanced Tracking Settings section of the Tracking tab)
    • For multiple GPU configuration the new algorithm will be used if number of cameras / sensors is not more than 4 (in this case only the primary GPU is used). In most cases this will still be faster than using multiple GPUs with the old tracking algorithm. For more than 4 cameras the old algorithm on multiple GPUs will be used, as a faster option.

ver. 3.3.10.206

Version 3.3.10.206
Sep 23, 2016
Download-24.png  Download

 B U G    F I X E S:

  • Jitter removal crashed on projects recorded with Kinect v1 containing RGB video information.

 U N D E R    T H E    H O O D:

  • Further improvement of responsiveness of user interface during jitter removal on computers with slow video cards.

ver. 3.3.9.205

Version 3.3.9.205
Sep 15, 2016
Download-24.png  Download

 N E W    F E A T U R E S:

  • Further increase of jitter removal speed. Improved algorithm is 10-20% faster compared to the previous release. Speed increase depends on particular hardware (GPU and CPU).

 B U G    F I X E S:

  • Biomech Add-on free trial activation did not work.
  • Periodic Auto-Save did not work in jitter removal. Now the project is saved every 30 seconds.
  • Memory leaks in jitter removal.
  • Crashed if timeline slider is clicked during jitter removal or tracking operation.

 U N D E R    T H E    H O O D:

  • Improved responsiveness of user interface during jitter removal on computers with slow video cards.

ver. 3.3.8.204

Version 3.3.8.204
Sep 01, 2016
Download-24.png  Download

 N E W    F E A T U R E S:

  • Increased speed of jitter removal. New algorithm is 3-7 times faster compared to the previous one. Speed increase depends on particular hardware (GPU and CPU).
  • Trajectory filter is improved for noisy data.

 B U G    F I X E S:

  • Tracking operations of multiple depth sensors projects failed with exception on some models of Nvidia cards using drivers 372.54, 372.70.

ver. 3.3.7.203

Version 3.3.7.203
Jul 14, 2016
Download-24.png  Download

 N E W    F E A T U R E S:

  • iPi Automation Add-on released.
    This tool allows to control iPi Recorder and iPi Mocap Studio from external application by sending JSON commands via Windows dll. It can be used for:
    • Using iPi Recorder and iPi Mocap Studio as a part of a third-party solution;
    • Automation of repeatable tasks;
    • Automation of custom workflow.
Note.png
Note: Add-on is not a free update and requires separate license key. 30-days free trial is available. For more information please read iPi Automation Add-on documentation.

ver. 3.2.7.201

Version 3.2.7.201
May 03, 2016
Download-24.png  Download

 B U G    F I X E S:

  • Jitter Removal failed on some models of video cards.

ver. 3.2.6.200

Version 3.2.6.200
Apr 25, 2016
Download-24.png  Download

 N E W    F E A T U R E S:.

  • Increased tracking quality for actors with adjusted proportions.
  • Allow opening of a processed .iPiMotion file without video, for 3D data viewing.
  • Hide Background option button / menu item for RGB video.
  • Improved UI for light settings:
    • Store light settings to scene file;
    • Automatic loading of light settings from previous project when creating new project;
    • Place Light to the Current Virtual Camera Position button added to Scene tab.
  • No Auto-Play after project open.
  • Calibration: UI enhancements for manual marking of ground points.
  • Calibration: edit box for typing in camera height added.
  • Control for manual alignment of coordinate system on the Scene tab.
  • Biomech export: added lengths of body segments, eye positions.
  • Support of Intel RealSense R200 sensor.
    • Please be aware that R200 depth quality is lower compared to Kinect sensors so far, so tracking accuracy may deteriorate.

 U N D E R    T H E    H O O D:

  • Calibration: additional ground detection quality check.


ver. 3.2.5.193

Version 3.2.5.193
Nov 19, 2015
Download-24.png  Download

 N E W    F E A T U R E S:

 B U G    F I X E S:

  • Update target character pose after Refit Pose.

 U N D E R    T H E    H O O D:

  • Do not auto play on project opening or after importing a target character.


ver. 3.2.4.191

Version 3.2.4.191
Aug 24, 2015
Download-24.png  Download

 N E W    F E A T U R E S:

  • Improvements in pose editing tools:
    • Highlighting selectable objects (e.g. bones) on mouse hover;
    • Rendering tool controls in front of all objects for ease of use;
    • Displaying highlighted bone’s name in the bottom-right (previously, only selected bone’s name was displayed).
  • Improvements in editing of motion profiles:
    • Ability to select target bones directly from target character’s skeleton in the scene;
    • Highlighting target character’s bones when scrolling through combo boxes in Target Bone column;
    • Automatic assignment of symmetric bones (left/right).
  • Minor improvements in rendering of the scene.

 B U G    F I X E S:

  • Compatibility of secondary GPUs is determined incorrectly.
  • Application crashes when the Pose Mismatch view is activated on multiple GPUs.
  • Initial length of ROI and Take 1 is defined improperly in projects created from records with non-standard frame rate (recorded after warning about low frame rate).
  • Pose of target character is not updated when actor’s pose is manually edited while staying on the same frame.


ver. 3.2.3.190

Version 3.2.3.190
Aug 08, 2015
Download-24.png  Download

 N E W    F E A T U R E S:

  • Visual bone picker. Located in drop-down of the Select button in the top toolbar and on the Pose tab.

release-notes-3.2.3.190-visual-bone-picker.png

 B U G    F I X E S:

  • Performance degradation when using multiple GPUs in certain configurations.
  • Sound controls are missing in the bottom toolbar for projects with audio data.
  • Calibration freezes under rare conditions.
  • Application crash during calibration when applying to an action video by mistake in certain situations.

 U N D E R    T H E    H O O D:

  • Improved background subtraction for records made with Kinect 2 sensors to keep more details.


ver. 3.2.2.189

Version 3.2.2.189
Jun 17, 2015
Download-24.png  Download

 N E W    F E A T U R E S:

  • Improved color picture quality for PlayStation Eye cameras and Kinect v1 depth sensors.
  • Dropped support for DirectX 10 video cards.
    Previously many core operations like tracking were already unavailable for such cards. Now program will not run at all.

 B U G    F I X E S:

  • Incorrect marker detection during calibration on some records. Only AMD and Intel GPUs were affected.
  • Incorrect character rendering on Intel HD4xxx series and above.
    This issue may still occur on prolonged running of application. In this case restarting the application helps.

 U N D E R    T H E    H O O D:

  • Some optimizations in usage of graphic resources.
  • Correct installation of older version over newer one.
    Previously uninstallation was required.


ver. 3.2.1.187

Version 3.2.1.187
May 02, 2015
Download-24.png  Download

 N E W    F E A T U R E S:

  • Substantial speed-up of marker detection during the calibration. (Up to 3 times depending on hardware and settings).

 B U G    F I X E S:

  • UI freezing when in the Pose Mismatch mode under certain conditions.
  • Incorrect rendering of video frame on some video cards.
  • Import of a target character with the same skeleton structure as the model in Mocap Studio results in error.
  • Incorrect values displayed for occlusions percent in the calibration statistics.


ver. 3.2.0.182

Version 3.2.0.182
Apr 20, 2015
Download-24.png  Download

 N E W    F E A T U R E S:

  • Added settings for adjusting proportions of the actor's model:
    • legs length;
    • arms length;
    • shoulders width;
    • head size;
    • feet size.
  • Layout of the Actor tab has been changed slightly.
  • Settings for adjusting the size of a light marker in calibration projects.
  • Improved automatic evaluation of calibration quality for multiple depth sensors.

 U N D E R    T H E    H O O D:

  • Improved processing of program crashes.


ver. 3.1.2.177

Version 3.1.2.177
Mar 19, 2015
Download-24.png  Download

 N E W    F E A T U R E S:


ver. 3.1.1.175

Version 3.1.1.175
Feb 24, 2015
Download-24.png  Download

 N E W    F E A T U R E S:

  • New menu items View > Cameras and View > Source of Light allow to remove camera and source of light objects from 3D scene if needed.

 B U G    F I X E S:

  • FBX import and export do not support national (non-ASCII) characters in file path.
  • Projects with three actors are always created in .iPiLocked format even in Pro edition.


ver. 3.1.0.173

Version 3.1.0.173
Feb 20, 2015
Download-24.png  Download

 N E W    F E A T U R E S:

  • Basic and Free Trial editions now support up to six (6) color cameras like Sony PS3 Eye. In previous versions this limit was four (4).
  • Pro edition now supports up to sixteen (16) color cameras like Sony PS3 Eye. In previous versions this limit was eight (8).
  • Pro edition now supports up to four (4) depth sensors. In previous versions this limit was three (3).
  • Pro edition now supports up to three (3) actors tracking. In previous versions this limit was two (2).
    Note.png
    Note: For three actors tracking it is highly recommended to use at least nine (9) color cameras like Sony PS3 Eye.
  • Extended and Extreme calibration modes for complex cases.
  • Bunch of minor improvements.

 B U G    F I X E S:

  • In rare cases calibration results in upside down configuration.
  • In rare cases Pause button is not clickable.


ver. 3.0.3.172

Version 3.0.3.172
Jan 07, 2015
Download-24.png  Download

 N E W    F E A T U R E S:

  • Improved progress indication for some operations - for example, video export and data export in Biomech addon. Removed progress indication in the scene (the spinning "wheel").
  • Scaling the actor's model relative to the floor when adjusting its height.

 B U G    F I X E S:

  • App crash during the calibration of dual Kinect 2 configuration using a board.
  • App crash during the export of point cloud from Kinect 2.
  • App crash when trying to remove an entry from the list of MRU hand poses.


ver. 3.0.2.171

Version 3.0.2.171
Nov 26, 2014
Download-24.png  Download

 N E W    F E A T U R E S:

  • Additional improvements in calibration procedure:
    • flashlight marker detection becomes faster and more robust;
    • calibration of multiple Kinect 2 sensors with the aid of flashlight is now supported;
    • undo/redo is now fully functional for calibration projects;
    • automatic detection of ground points is slightly improved to become more reliable in complex cases.
  • Options for FBX export:
    • FBX version;
    • Binary/ASCII format.
  • Manual ground height fine-tuning for action projects (Scene tab).
  • Message about incompatible video card on execution of Tracking / Refine / Refit Pose if video card is not DirectX 11 capable.
  • Reduced memory footprint.

 B R E A K I N G    C H A N G E S:

  • Binary format of project files is slightly changed. This version can open projects saved by previous versions. But previous versions are unable to open projects saved by this version.

 B U G    F I X E S:

  • Tracking overrides key frames for hands.
  • Wrong position of video billboard for projects from depth sensors when alignment of color video to depth is switched off.
  • FBX import/export doesn't work in rear cases: OS is Windows 7 64-bit, Service Pack 1 is not installed, CPU supports AVX instructions set (e.g. Intel Core i3/i5/i7 Haswell).
  • Fatal error "NullReferenceException" during application start up in rear cases.
  • Minor bugs in visibility of imported character's bones and opacity of imported character's skin.


ver. 3.0.1.169

Version 3.0.1.169
Nov 11, 2014
Download-24.png  Download

 N E W    F E A T U R E S:

  • Disabling tabs area and some keyboard shortcuts during processing to prevent unintentional interruption of operation.

 B U G    F I X E S:

  • Crash on start on hardware configurations with high resolution display and 2 GB (or less) video card.
  • Processing speed degradation on Windows 7.
  • Rare false failure of integrity check in certain environments.


ver. 3.0.0.166

Version 3.0.0.166
Nov 03, 2014
Download-24.png  Download

The first public release of iPi Mocap Studio 3. If you're user of iPi Studio 2.x or iPi Studio 1.x then please visit Migration to V3 from Older Versions article.

 N E W    F E A T U R E S:

  • Support of new depth sensors: Kinect for Xbox One / Kinect 2 for Windows.
  • Improved calibration:
    • more reliable;
    • faster;
    • automatic ground detection;
    • calibration quality feedback.
  • Improved tracking for arms and legs.
  • Redesigned user interface.
  • Comprehensive progress indicators.
  • Improved user interface for animation export and motion transfer.
  • More accurate center of mass calculation.
  • Tons of minor improvements and fixes.

 B R E A K I N G    C H A N G E S:

 U N D E R    T H E    H O O D:

  • Migration to DirectX 11.
  • Moving to Microsoft .Net 4.5.1 Platform.
  • Using new installation and auto-update system instead of buggy ClickOnce technology.